Mac OS

Customize hidden settings

These are my top preferred settings for Mac OS, which can be changed using the defaults command line tool in Terminal.

Copy File Contents from Quick Look

defaults write com.apple.finder QLEnableTextSelection -bool true

Show Hidden Files

defaults write com.apple.finder AppleShowAllFiles -bool YES
killall Finder

Disable Gatekeeper

sudo spctl --master-disable

Disable Software Updates

sudo softwareupdate --ignore "macOS Catalina"

Disable Window Animations (OS X Lion)

defaults write NSGlobalDomain \
NSAutomaticWindowAnimationsEnabled -bool NO
killall Dock

Show Full Paths

defaults write com.apple.finder \
_FXShowPosixPathInTitle -bool YES

Don’t create .DS_Store clutter on Network and Windows (non-native) volumes

defaults write com.apple.desktopservices \
DSDontWriteNetworkStores -bool YES

Save and Print dialog boxes expanded by default

defaults write -g \
NSNavPanelExpandedStateForSaveMode -bool YES
defaults write -g \
MPrintingExpandedStateForPrint -bool YES

Set default picture for Desktop and Login Screen

sudo defaults write \
/Library/Preferences/com.apple.loginwindow \
DesktopPicture "/Library/Desktop Pictures/Vacation Photo.jpg"

Screen captures in TIFF [or PNG] format

defaults write com.apple.screencapture type tif
defaults write com.apple.screencapture type png

Screen Sharing additional toolbar buttons

defaults write com.apple.ScreenSharing \
'NSToolbar Configuration ControlToolbar' \
-dict-add 'TB Item Identifiers' \
'(Scale,Control,Share,Curtain,Capture,
FullScreen,GetClipboard,SendClipboard,Quality)'

Preferences for Mac

Enable the Startup Chime on Mac (if it has a built-in speaker of course!)

sudo nvram StartupMute=%00 

Leave a Reply